Document Imaging Unavailable

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 22:05 EDT

Monitoring

The Document Imaging service is now up and accessible. The UMass Presidents Office and UMass Lowell teams continue to monitor all related services.
Posted Oct 28, 2025 - 12:07 EDT

Investigating

The Document Imaging service is currently unavailable. The UMass Presidents Office is investigating and an update will be provided here by 11:00am or sooner if additional information is available.
Posted Oct 28, 2025 - 09:16 EDT
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).