Power outage on South campus
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 12:02 EDT
Update
As of 11:05am on June 29, all South campus network and phone services have been restored. If you experience any issues, please contact TechServices at help@uml.edu or 978-934-4357. We will continue to monitor services across campus.
Posted Jun 29, 2022 - 11:07 EDT
Monitoring
The UMass Lowell South campus has experienced a brief power outage. Power was down for several minutes and appears to be coming back up. This outage caused many network and phone services on South campus to go down. We will be monitoring services and will remediate any services which require additional work.
Posted Jun 29, 2022 - 10:33 EDT
This incident affected: Connectivity (Campus Internet, Wi-Fi, Network Infrastructure, Telephony).