DocuSign Offline
Incident Report for UMass Lowell
Resolved
As of 8:10 PM on May 25, DocuSign reports that the latency and performance issues have been resolved. All DocuSign services should be operating normally.
Posted May 25, 2022 - 20:41 EDT
Update
As of 6:00 PM on May 25, DocuSign continues to report latency and performance issues. Users should be advised that they may experience issues using the DocuSign application. UMass Lowell IT will be monitoring throughout the evening of May 25 and morning of May 26. We will update this page at 9:00 AM on May 26, or earlier if there is any change in DocuSign status.
Posted May 25, 2022 - 18:09 EDT
Update
As of 3:00 PM on May 25, DocuSign is reporting latency and performance issues. Users should be advised that they may experience issues using the DocuSign application. UMass Lowell IT continues to monitor the situation. The next update will be at 6:00 PM or when status changes - whichever comes first.
Posted May 25, 2022 - 16:35 EDT
Monitoring
As of 7:57 PM on May 24, the DocuSign application is reported to be operational. UMass Lowell IT will be monitoring throughout the evening of May 24 and morning of May 25. The next update to this page will be at 9:00 AM on May 25, or should the status change, whichever is sooner.
Posted May 24, 2022 - 20:03 EDT
Update
As of 6:00 PM on May 24, the DocuSign application continues to be offline. UMass Lowell IT is monitoring the situation. Because this application is hosted in the cloud, UMass Lowell is unable to restore services independently. Our next update will be at 8 PM or when services are restored, whichever is sooner.
Posted May 24, 2022 - 17:58 EDT
Identified
DocuSign is a hosted application that UMass Lowell uses for document approval and electronic signatures. The provider of the software has announced large-scale availability and operational issues that are ongoing. At this time, no resolution or expected time of repair is available. This site will be updated every two hours, or upon service restoration, whichever comes first.
Posted May 24, 2022 - 16:02 EDT
This incident affected: ERP / Line of Business Software (DocuSign).