Multiple applications unavailable

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 10:53 EDT

Update

As of 8:05 PM EDT, Microsoft has resolved the global outage with their content delivery service.

The earlier mitigations that restored availability for Digital Experience applications and Single Sign-On have been reverted and are now fully operational. myUML is fully operational.

The UMass Lowell website (www.uml.edu) will continue to operate with the earlier mitigations in place until Thursday, October 30. As a result, some pages on www.uml.edu may not load properly.

Additional updates will be provided as events warrant.
Posted Oct 29, 2025 - 22:23 EDT

Update

The availability of Digital Experience applications, Single Sign-On, and myUML has been restored as of 2:15 PM EDT. Some images and fonts may not load correctly within some DX apps. myUML is only accessible via uml.edu/my or uml.edu/now. Additional updates will be provided as events warrant.
Posted Oct 29, 2025 - 14:21 EDT

Update

We are actively working to restore the availability of Digital Experience applications, including myUML and DX Single Sign-On.

Microsoft has updated their incident to a global Azure network infrastructure outage, which may be impacting other Microsoft services. Currently, Microsoft Entra Single-Sign On is degraded and users attempting to sign in to UMass Lowell SSO-protected systems may experience slowness during the authentication process.

Additional updates will be provided as events warrant.
Posted Oct 29, 2025 - 13:41 EDT

Update

The www.uml.edu website availability issue has been mitigated. Some pages on www.uml.edu may still appear broken. Additional updates will be provided as events warrant.
Posted Oct 29, 2025 - 12:44 EDT

Identified

The cause of this issue has been identified as a global outage with a Microsoft Azure content delivery network. Other services and third-party applications may also be impacted. Additional updates will be provided as events warrant.
Posted Oct 29, 2025 - 12:13 EDT

Investigating

Multiple Digital Experience applications are unavailable and www.uml.edu may not be loading. We are investigating this issue and will provide updates as events warrant.
Posted Oct 29, 2025 - 12:00 EDT
This incident affected: Digital Experience (www.uml.edu, myUML (formerly Now/Student Dashboard), DX Apps, DX Single Sign-On) and Authentication and Security (Microsoft Entra single sign-on (SSO)).