Outbound International Phone Calls
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Aug 30, 2022 - 15:34 EDT
Monitoring
The issue with international dialing has been resolved. We will continue to monitor our systems to ensure services are working properly.
Posted Aug 30, 2022 - 10:29 EDT
Identified
The university's telephone carrier has identified the cause of the international calling issue and is implementing a fix now. This status page will be updated when more information is available.
Posted Aug 29, 2022 - 21:19 EDT
Investigating
We are experiencing problems making outbound phone calls to some international numbers including those in Ghana, Nepal, and Nigeria. Our carrier is investigating the issue. This status page will be updated when more information is available.
Posted Aug 29, 2022 - 14:11 EDT
This incident affected: Connectivity (Telephony).