Multiple applications degraded

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 11:56 EDT

Monitoring

The cause of this issue has not yet been identified. However, our monitoring systems indicate the issue has subsided and all affected systems are functioning normally as of 12:10 PM EDT. We will continue to monitor and provide updates as events warrant.
Posted Oct 28, 2025 - 13:19 EDT

Investigating

Multiple Digital Experience applications are degraded and may intermittently fail to load or process some requests. This issue began at approximately 6:00 AM EDT. We are working with the President's Office to resolve this issue and will provide updates as events warrant.

Affected Digital Experience applications include:

myUML (formerly Now/Student Dashboard)
Academic Success Alerts
Attendance
Blackboard Course Management (excludes Blackboard LMS)
Blackboard Feed (excludes Blackboard LMS)
Canvas Course Management (excludes Canvas LMS)
Canvas Feed (excludes Canvas LMS)
Course Master
Faculty Portal
Lecture Capture Requests
River Hawk Experience Distinction
UCAPS Photo Uploads
Posted Oct 28, 2025 - 10:31 EDT
This incident affected: Digital Experience (myUML (formerly Now/Student Dashboard), DX Apps).