Partial Internet Outage
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 20:33 EDT
Monitoring
Our Internet connectivity has been fully restored, and our ISP continues to investigate. UMass Lowell IT will continue to monitor connectivity.
Posted Mar 21, 2024 - 07:47 EDT
Investigating
UMass Lowell is experiencing a partial Internet outage, caused by an upstream issue from our Internet Service Provider. Some Internet sites are reachable while others are not. We are actively in communication with our ISP and this site will be updated as we have more information.
Posted Mar 21, 2024 - 07:35 EDT
This incident affected: Connectivity (Campus Internet, Telephony).