Microsoft Exchange Online Issues
Incident Report for UMass Lowell
Resolved
This issue has been resolved.
Posted Jun 13, 2023 - 18:12 EDT
Monitoring
Microsoft has stated that they have "reverted a change which occurred just prior to impact starting" and that "telemetry is showing significant improvement in availability across the service. Additionally, we've received confirmation from previously impacted users that the issue is no longer occurring."

Both Microsoft and UMass Lowell IT will continue to monitor for the remainder of the day. At this time, if you have any further issues with Outlook, Teams, Sharepoint, or OneDrive, please contact TechServices at 978.934.4357.
Posted Jun 05, 2023 - 12:40 EDT
Identified
Microsoft has acknowledged that an update they applied is causing issues. We have no ETA on resolution, but Microsoft is actively working to restore service availability.
Posted Jun 05, 2023 - 11:33 EDT
Investigating
Microsoft is currently reporting an unspecified issue with Microsoft 365 that is impacting Outlook online, as well as some links in emails. Information Technology is monitoring Microsoft's investigation. This issue is impacting Microsoft customers globally, and it's not limited to UMass Lowell.
Posted Jun 05, 2023 - 10:50 EDT
This incident affected: Collaboration Tools (Email, Microsoft Teams).