Student System Performance Issues

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 11:15 EDT

Investigating

Information Technology is investigating reports of degraded SiS functionality including search not working and SiS generated report errors. UITS is actively working on the issue.

We will provide additional updates as more information becomes available. We apologize for the inconvenience and appreciate your patience.

Our next update will be provided by 5:00 or sooner if the status changes.
Posted Jun 12, 2026 - 09:30 EDT
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).