Echo360 outage
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 16:06 EST
Monitoring
All Echo360 Lecture Capture services have been restored. IT will continue to monitor these services to ensure continued availability.
Posted Dec 20, 2023 - 18:18 EST
Investigating
We are aware that the Echo360 Lecture Capture system is not available. The vendor is aware of the issue and is working with their hosting provider to restore all services. An update will be provided here when we have more information.
Posted Dec 20, 2023 - 16:02 EST
This incident affected: Academic Technology (Echo360 (Lecture Capture)).