SiS Unavailable

Incident Report for UMass Lowell

Resolved

UITS reports that the service disruption affecting SiS has been resolved. We apologize for any inconvenience and appreciate your patience. If you believe you are still impacted, please contact TechServices for support.
Posted Jan 15, 2026 - 10:40 EST

Investigating

UITS has identified an issue with SiS which is currently intermittently unavailable. They are investigating. We will continue to update this incident with further details as they become available. Our next update will be at 11:00 or if the status changes, whichever comes first. Thank you for your patience.
Posted Jan 15, 2026 - 09:31 EST
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).