Partial phone service outage
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Oct 26, 2022 - 15:27 EDT
Monitoring
The telephony issue has been resolved and we continue to monitor all systems.
Posted Oct 26, 2022 - 12:05 EDT
Investigating
We are experiencing a partial outage affecting specific incoming phone calls. We are actively working to resolve this issue and an update will be posted when we have more information.
Posted Oct 26, 2022 - 11:26 EDT
This incident affected: Connectivity (Telephony).