Parking lot status information unavailable
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 23:12 EST
Identified
Parking lot status information is currently unavailable. Lot status and available spaces are not available via Maps (uml.edu/maps), Student Dashboard (Now), or the UMass Lowell Parking app. We will provide updates as events warrant.
Posted Nov 15, 2022 - 21:13 EST
This incident affected: Web Services (API).