Microsoft Teams
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Jan 28, 2024 - 20:46 EST
Monitoring
Microsoft has confirmed that all service and features in Microsoft Teams have been restored and are performing normally. IT will continue to monitor these services to ensure availability.
Posted Jan 27, 2024 - 08:51 EST
Update
Update from Microsoft as of 7:22pm: We’re seeing significant improvements with many of the Teams features affected by this incident as we continue to apply mitigations and optimize traffic. The following areas of functionality are still affected and/or are being evaluated:
* Sending and receiving read receipt notifications may be delayed
* Users may experience issues resuming or rejoining meetings
* Users may not able to log into Teams after rebooting their system
* Some users were experiencing delays sending and receiving chat messages. We believe this has been largely addressed although some users may still experience brief delays
Posted Jan 26, 2024 - 20:54 EST
Update
Update at 3:00pm: Microsoft continues to implement configuration changes within their environment to reduce customer impacts as quickly as possible. This status page will be updated as more information is made available.
Posted Jan 26, 2024 - 15:24 EST
Identified
Microsoft reports that, as part of the failover process, they are currently scaling up their alternate infrastructure so all traffic can be distributed to their alternate infrastructure.

Note: UMass Lowell phone calls and meetings in Teams appear to be working as expected and do not seem to be impacted.
Posted Jan 26, 2024 - 13:51 EST
Investigating
1:15pm: Microsoft has posted a service health advisory to report multiple issues with Teams. Microsoft reports that these issues started shortly before 11am and IT can confirm that users at UMass Lowell are experiencing some of these issues.

Microsoft reports that these issues can include, but are not limited to, the following functionality:
* Users may not able to log into Teams after rebooting their system
* Users logging in or unlocking their devices after some time may see missing messages
* Users may fail to load messages in channels and chats
* Users may be unable to view or download their images, videos, audio, etc
* Some messages may experience delays being sent
* Sending and receiving read receipt notifications may be delayed

Microsoft has identified that a portion of the Microsoft Teams service is experiencing internal issues. They are performing a failover to an alternate infrastructure to remediate impact. An update will be provided here as more information becomes available.
Posted Jan 26, 2024 - 13:24 EST
This incident affected: Collaboration Tools (Microsoft Teams).