Network & phone services are unavailable at the Haverhill and Andover locations
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Nov 13, 2022 - 13:17 EST
Monitoring
All network and phone services have been restored in the Andover and Haverhill locations. With this restoration, all UMass Lowell services are 100% operational. We will continue to monitor services to ensure proper connectivity.
Posted Nov 12, 2022 - 08:05 EST
Identified
The fiber repair crew had to replace another damaged portion of fiber which is impacting all network and phone service in Haverhill and Andover. This page will be updated when we have more information.
Posted Nov 11, 2022 - 17:35 EST
Monitoring
All services have been restored.
Posted Nov 11, 2022 - 14:30 EST
Update
All network and phone services have been restored at the Inn & Conference Center, and at 110 Canal Street. With this restoration, all services on the Lowell campus are 100% operational.

Our vendor is still working on the link to the Haverhill campus, and an update will be provided here when we have more information.
Posted Nov 10, 2022 - 18:03 EST
Update
Our vendors are still working to replace the damaged fiber connectivity to Haverhill, the ICC, and 110 Canal. The damage is extensive and the work includes replacing a damaged telephone pole, running a few hundred feet of fiber optic lines, and splicing nearly 200 fiber optic strands. We are monitoring all services and will restore connectivity as soon as the repairs have been made.
Posted Nov 10, 2022 - 14:16 EST
Identified
Network and phone services in Haverhill, the Inn and Conference Center, and 110 Canal remain down while repairs are underway. Crews are on site and working to restore fiber connectivity to those locations. Repairs are expected to be complete sometime today. All other campus services and locations are fully operational.
Posted Nov 10, 2022 - 10:34 EST
Update
Update: South campus network services have been restored, but services at the ICC, 110 Canal, and the Haverhill campus are still down. Crews will be on-site first thing Thursday morning to begin making repairs to the fiber optic lines damaged by the fire. Additional information will be provided as it becomes available.
Posted Nov 09, 2022 - 21:28 EST
Update
Update: Some WiFi services on South campus are also affected. We continue to investigate - an update will be provided when we have more information.
Posted Nov 09, 2022 - 17:58 EST
Investigating
Network and phone services in the following buildings are down (all others are not impacted at this time):
* Mahoney Hall
* South Power Plant
* Inn & Conference Center
* 110 Canal
* Haverhill

We are actively investigating, but it may be related to a fire in Lowell. An updated status will provided when we know more.
Posted Nov 09, 2022 - 15:25 EST
This incident affected: Connectivity (Campus Internet, Network Infrastructure, Telephony).