HR Direct Degraded Performance
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 11:04 EDT
Monitoring
The slowness issue with HR Direct has been successfully resolved. We will continue to monitor this service to ensure continued availability.
Posted Sep 21, 2023 - 16:54 EDT
Identified
Our partners are implementing a fix for this issue. An update will be posted when we have additional information.
Posted Sep 21, 2023 - 16:06 EDT
Investigating
The HR Direct System is intermittently slow. You may experience slowness or error messages when logging in or navigating the HR Direct system. Our partners are investigating and apologize for the inconvenience. An update will be posted when we have additional information.
Posted Sep 21, 2023 - 13:35 EDT
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).