UMass Lowell web site

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Jun 08, 2022 - 15:02 EDT

Update

We are continuing to investigate this issue.
Posted Jun 08, 2022 - 15:01 EDT

Investigating

The UMass Lowell web site is not loading properly. The Web Office is investigating the issue and this page will be updated when there is more information.
Posted Jun 08, 2022 - 14:29 EDT
This incident affected: Digital Experience (www.uml.edu).