We are continuing to monitor for any further issues.
Posted Dec 19, 2025 - 19:05 EST
Monitoring
At this time, Information Technology has restored network connectivity in Dugan. IT will continue to monitor and will close this incident at 3:00 PM today.
If you experience any issues, please contact TechServices at 978.934.4357. Thank you for your patience, and please stay safe during this weather event.
Posted Dec 19, 2025 - 13:19 EST
Identified
Information Technology has identified the cause of the Dugan network issues. A piece of equipment was damaged during the recent power outage. A Network Services team is onsite and is working to restore connectivity as quickly as possible. We anticipate full restoration before 1:00 PM.
We will continue to update this incident with further details as they become available. Our next update will be at 1:00 PM or if the status changes, whichever comes first.
Posted Dec 19, 2025 - 12:20 EST
Investigating
Information Technology is aware of an interruption in network connectivity in Dugan Hall. While this is likely due to the recent power outage, we are assessing the situation.
We will update this incident with further details as they become available. We apologize for any inconvenience this may have caused. Our next update will be at 1:00 PM or if the status changes, whichever comes first.
Posted Dec 19, 2025 - 12:15 EST
This incident affected: Connectivity (Network Infrastructure).