Phone service outage
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 15:22 EST
Monitoring
This inbound and outbound phone issue has been traced to a firewall issue, which has been fixed. All inbound and outbound calls are working properly. We will continue to monitor these services to ensure continued availability.
Posted Feb 15, 2024 - 17:06 EST
Identified
We are seeing an issue again with incoming and outgoing calls. We are working on a fix and this page will be updated as soon as we have more information.
Posted Feb 15, 2024 - 16:23 EST
Monitoring
This issue has been fixed - all inbound and outbound calls are working properly. We will continue to monitor these services to ensure continued availability.
Posted Feb 15, 2024 - 15:34 EST
Investigating
Information Technology is aware of an outage impacting telephone services on campus. Inbound and outbound calling is not functional, but internal calling within the university is working. Emergency calling services are being forwarded to UML Dispatch.

This page will be updated as more information becomes available.
Posted Feb 15, 2024 - 15:07 EST
This incident affected: Connectivity (Telephony).