Power outage on South campus
Incident Report for UMass Lowell
Resolved
Power has been restored to South campus and all network/voice services are now available.
Posted Jun 30, 2022 - 15:29 EDT
Investigating
The UMass Lowell South campus has experienced a power outage. Power is down and is affecting many network & phone services on South campus to go down. UMass Lowell Facilities is aware of the issue and National Grid is working on it. An update will be posted when more information is available.
Posted Jun 30, 2022 - 14:13 EDT
This incident affected: Connectivity (Campus Internet, Wi-Fi, Network Infrastructure, Telephony).