Azure DNS Services
Incident Report for UMass Lowell
Resolved
At this time, Information Technology believes that the issue with Azure DNS is resolved. We do not expect it to recur. We apologize for any inconvenience this may have caused.
Posted Jun 08, 2022 - 23:51 EDT
Monitoring
Earlier today, UMass Lowell's external DNS resolution stopped resolving addresses, leading to website issues, as well as issues with other externally-facing applications. This outage is a result of a presumed failure in the Microsoft Azure DNS Names service. The service returned to operable status without any action from UMass Lowell. Information Technology believes the issue is resolved, and will continue to monitor. Our next update will be at 6:00 PM, unless the status changes.
Posted Jun 08, 2022 - 15:27 EDT
This incident affected: Connectivity (DNS).